CHAPTER 6 HANDLING CREDIT CARD TRANSACTIONS

Introduction
All web applications and the resulting permit fees for web applications in Nevada are paid using a credit card. SCI and our clients accept MasterCard™, VISA™, American Express™, and Discover™ cards. The Application Hunt System uses a commercial credit card gateway, Authorize.Net®, for all credit card transactions.

WEB APPLICATIONS
Web application credit card charges are authorized, settled, and fulfilled in the Web Apps application and then imported into AHS.

The hunter enters his credit card information on the secure web site to pay the Application Fee, the Predator Management Fee, the Convenience Fee, and any donations the hunter desires to make to Operation Game Thief or Predator Management.

When the hunter clicks Submit, the credit card information is transmitted to Authorize.Net® for validation. The transmission is an XML document containing a unique Order Number, the Name, the Credit Card Number, the Expiration Date, and the Amount. The transaction transmission is protected by the VeriSign™ security system for online payments using 128 bit encryption. Authorize.Net® then obtains payment authorization from the credit card issuer, usually a bank or credit union, and transmits an XML document to the HuntNevada web site containing the Order Number, the Amount, the Authorization Number, the Positive Address Verification (PAV), a Risk Factor based on credit card company factors, and an error code if the card is declined.

The PAV (also known as Address Verification System - AVS) feature compares the credit card billing address numerical information submitted with the hunter’s credit card to the provider’s database and
yields a code for exact match, substantial match, or mismatch. As implemented in AHS, the system does not reject a charge based on a PAV/AVS mismatch, however.

For web transactions, the hunter receives immediate notification that his card has been accepted and the Authorization Code from the provider is entered into the application record in WebApps, the database underlying HuntNevada; the application and the funds must be imported into AHS after settlement.

Our application credit card transactions are sent to Authorize.Net™ as fulfilled, since that signifies that we have accepted the application. This is important because a vendor may not settle a charge against a credit card until the service is rendered or the merchandise shipped.

If the card is declined, the hunter is notified on the web site and returned to the credit card information screen to make corrections or to apply with a different card. If an authorization cannot be obtained, the transaction is not completed.

The transactions can be viewed in WebApps by authorized personnel prior to settlement. A sample screen is shown in Figure 6-1. This list will be compared to the list furnished by Authorize.Net after the nightly settlement to ensure that all transactions settled.

Duplicate transactions can occur if the web client presses the Submit button multiple times. If the duplicate is discovered before settlement, the credit card supervisor can mark the duplicate transaction Incomplete in the Settlement Browse and void it. If it occurs after Authorize.Net settles the transaction, the duplicate must be backed out using a credit entry.
Web application transactions are settled nightly at 10:00 PM Pacific Time for the previous 24-hour period by Authorize.Net. Authorize.Net creates its own batches and assigns a batch number to the transactions based on the Julian Date.

The Credit card Supervisor logs into Authorize.net using the PPMID, a Merchant ID Account Number. Nevada uses 2 PPMIDs for each draw, one for application fees and one for permits, licenses, and stamps sold through the HuntNevada web site in conjunction with a draw.
The Authorize.Net™ batch files are downloaded by the credit card supervisor for each open draw and Merchant Account Number. The form used in Web Apps is shown in Figure 6-2.

The web application settlement batch data is then imported into the WebApps database, a component of the web application, with a list of the dollar amounts and a count of the transactions in the Authorize.Net™ Batch for each of the four card types – Visa™, MasterCard™, Discover™, and American Express™.

The Credit Card Supervisor can settle each transaction individually by clicking it or click Mass Settle to mark all pending transactions on the list that have been settled by Authorize.net as settled in Web Apps.
Figure 6-2 Web Apps Mass Settlement
The final step in the web application credit card process is to mark the batch as fulfilled in the screen shown in Figure 6-3. The batch of applications is now ready for import into AHS.

The Nevada supervisor uses File>Applications>Processes>Data Entry>Import Web Apps to perform the import. The applications now exist in AHS and the batch is listed on the Application Batch Browse with a 600 prefix. It is then Posted by the Nevada Supervisor.

Transactions in Authorize.Net's system take 1-4 business days to clear with the credit card company, i.e. Master Card™, Visa™, American Express™, or Discover™, after which the card company pays the Wildlife Administrative Services Office’s merchant bank account. The bank then produces a report on credit card deposits received from each of the card providers. This report is manually reconciled against the Fulfillment Browse information by
Authorize.Net™ batch number, total amount by credit card provider, and number of transactions by credit card provider. This is done by the SCI Business manager.

Figure 6-4 Web Application Credit Card Process

WEB PERMITS AND LICENSES
If the online hunter’s application is successful in the draw, the process is repeated from within the Application Hunt System™ for payment of the tag and license fees. (The tag and license fees for successful paper applicants was submitted with the application by check.)

The major difference in the workflow for processing the tag and license fees is that the license and tag charges are created in the draw process and batch transmitted to Authorize.Net™ for approval all at once. Approval normally takes several days due to the number of charges. Figure 6-5 illustrates the flow for Credit Card Tag Charges.
The Credit Card Browse
To work with credit card transactions, click **File>Credit Cards**. **Credit Cards** is password protected, since the credit card data must be safeguarded. The login screen shown in Figure 6-6 displays. Enter the Credit Card Password and click **OK**.

**Figure 6-6 Credit Card Login Dialog Box**

The Credit Card Browse Form shown in Figure 6-7 appears. The data comes from the HAAUTHORIZE.NETCC table. We have removed all credit card numbers from the credit card screens in this manual to protect privacy. Normally, users with the appropriate level of access will see the client’s credit card number.

This form displays all the credit card transactions in the system in chronological order by Batch and Application Number. The fields are described below.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Batch</td>
<td>6-digit batch number beginning with 6 for web applications or Descriptor, i.e PERMIT</td>
</tr>
<tr>
<td>Year</td>
<td>is the Hunt Year</td>
</tr>
<tr>
<td>Draw</td>
<td>is the draw number for the application</td>
</tr>
<tr>
<td>Application Number</td>
<td>is the 6-digit Application Serial Number</td>
</tr>
<tr>
<td>Man Number</td>
<td>is the hunter’s Man Number</td>
</tr>
<tr>
<td>Credit Card Number</td>
<td>is the 16-digit credit card number (The card number has been redacted from all examples in this manual.)</td>
</tr>
<tr>
<td>Cardholder Name</td>
<td>name as it appears on the card</td>
</tr>
<tr>
<td>Status</td>
<td>Approved or Pending</td>
</tr>
<tr>
<td>Charge Amount</td>
<td>amount charged to the card in this transaction</td>
</tr>
<tr>
<td>Hold</td>
<td>The system sets this flag after three attempts to submit the card to prevent the declined transaction from being resubmitted to Authorize.Net™.</td>
</tr>
</tbody>
</table>
Figure 6-7 Credit Card Browse Form

To locate a specific transaction, select **Find Trans**. The Transaction Find Form in Figure 6-8 appears. You may use either the Application Number or the Credit Card Number as the search criteria. Once you have entered a criterion, click **Find** to locate the record.
Figure 6-8 Credit Card Transaction Search

The Credit Card Browse will scroll to the record and indicate it with the record pointer. Click **Detail** to display the information in the record in the Credit Card Detail Form shown in Figure 6-9. Note that there are two windows in this form. The upper window displays the credit card information, while the lower window shows the related application information. This accommodates situations in which the credit card used for the application belongs to someone other than the hunter on the application or in which the billing address differs from the home address.

In addition to the usual information, note the following credit card specific fields.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Card #</td>
<td>16-digit credit card number (not shown in manual)</td>
</tr>
<tr>
<td>Exp</td>
<td>expiration date in mm/yy format</td>
</tr>
<tr>
<td>Status</td>
<td>Approved, Pending, Referred, Call, or Declined</td>
</tr>
<tr>
<td>Address</td>
<td>Credit card billing address in upper window</td>
</tr>
<tr>
<td></td>
<td>Hunter address in lower window</td>
</tr>
<tr>
<td>Card Type</td>
<td>VISA™, MasterCard™, American Express™, Discover™</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Approval Number</td>
<td>Authorize.Net™ charge approval number</td>
</tr>
<tr>
<td>CC Batch</td>
<td>Authorize.Net™ credit card batch number</td>
</tr>
<tr>
<td>Settle Date</td>
<td>Date credit card provider billed</td>
</tr>
</tbody>
</table>

Data cannot be edited in this form.
There are a number of processes available in the Credit Card Browse as shown in Figure 6-10. We will discuss these transactions in the order they are likely to occur in processing credit card transactions. Remember that the web site processes the credit card transactions.
completely for the Application Fee, the Predator Management Fee, the Transaction Fee, and any donations, then posts the completed applications in the Client Browse, the Application Browse, and the Credit Card Browse. The Convenience Fee does not show in AHS at all, since it is not part of the application.

After the Draw, the tag and license fees for successful web applicants are charged to the hunter’s credit card from within the Application Hunt System™.

Figure 6-10 Credit Card Browse Form Processes

The credit card transactions for each successful application are created in the Post-Draw Process, Sell Tags and Licenses. This step creates a table, HACCARD, listing all the tag and license charges and related information. HACCARD information populates the Credit Card Browse.

MARK TRANSACTIONS FULFILLED
This function is not currently used in Nevada, as the Application Hunt System marks all transactions fulfilled as they are transmitted to Authorize.Net™ for settlement.

CREATE PENDING TRANSACTIONS
Create Pending Transactions creates a second credit card table, HAPCARD, by rolling up the fees on each group application into one
charge preparatory to submitting the transactions to Authorize.Net for authorization. HAPCARD Data is not visible; the Credit Card Browse information comes from HACCARD.

**AUTHORIZE PENDING TRANSACTIONS**

Authorize Pending Transactions transmits all pending license and permit fee transactions to Authorize.Net for verification and payment authorization in an XML document. Authorize.Net validates the card information, performs the Positive Address Verification process, and obtains payment authorization from the credit card provider.

**AUTHORIZE.NET INFORMATION**

Click **Authorize.Net Information** to view the Authorize.Net batch transaction files in the Application Hunt System. The Authorize.Net Edit screen in Figure 6-11 appears.

![Figure 6-11 Authorize.Net Edit Form](image)

Authorize.Net transmits an electronic file to the Wildlife Administrative Services Office for verification against the Application Hunt System records. Click the **Import** button in the Authorize.Net Information Form to enter the Merchant ID for the file to be imported. Note that the first record starts with a 5 digit PPMID Number (26135), the Order Number (WT Key Field – 41396), the four-digit bank
identifier (4323), the name (Maclean), the transaction settlement date and time, three PAV checks (N/N/N in the example), the Authorize.Net™ Batch# (00053), and the amount of the charge ($17.50). This is a new order number, distinct from the Application Order Number.

Click the **Update** button to enter the HAPCARD into HACCARD. This ensures that the data is consistent across the two tables.

**SETTLE TRANSACTIONS**

In **Settle Transactions**, the file from Authorize.Net™ is compared to the Settlement data in the Application Hunt System™ to verify that all the charges were appropriately recorded in both places. Common errors include double billing in Authorize.Net™ and missing transactions.

The Authorize.Net Batch Total is compared to the Credit Card Settlement Form Batch Amount, the number of transactions in the batch and amount for each card type are compared, and queries are run to ensure that no double billing took place and that all transactions are recorded. The Credit Card Settlement Form is shown in Figure 6-12.

The Credit Card Settlement Form has the following fields:
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Batch ID #</td>
<td>Authorize.Net™ Batch Number</td>
</tr>
<tr>
<td>Batch Amount</td>
<td>Total of Charges in Authorize.Net™ Batch</td>
</tr>
<tr>
<td>Settlement Date/Time</td>
<td>Time and Date of Authorize.Net™ Settlement</td>
</tr>
<tr>
<td>Amex Amount/Transaction</td>
<td>American Express Batch Total/# of Transactions</td>
</tr>
<tr>
<td>Discover Amount/Transactions</td>
<td>Discover Total/# of Transactions</td>
</tr>
<tr>
<td>Master Card Amount/Transactions</td>
<td>MasterCard Total/# of Transactions</td>
</tr>
<tr>
<td>Visa Amount / Transactions</td>
<td>Visa Total/# of Transactions</td>
</tr>
<tr>
<td>Order Number Range</td>
<td>Authorize.Net™ Order Number Range</td>
</tr>
<tr>
<td>Authorize.Net File Data Imported</td>
<td>Authorize.Net™ Order Number for each transaction</td>
</tr>
<tr>
<td>Order</td>
<td>Date of each transaction</td>
</tr>
<tr>
<td>Tran Total</td>
<td>Total charge on each transaction</td>
</tr>
<tr>
<td>Card Type</td>
<td>Type of credit card</td>
</tr>
<tr>
<td>Cardholder</td>
<td>Cardholder Name</td>
</tr>
</tbody>
</table>
You must enter the Merchant ID, Batch Amount, Settlement Date and Time. Click Update to display the import file data in the lower window. All transactions sent to Authorize.Net™ will appear with those in the Batch selected highlighted. Alternatively, you can enter the first and last order numbers in the batch to display the data. Click Calculate to
determine the total amount and total number of transactions for each card type in the batch. The data will appear in the upper window. Add the amount for each card type and ensure that the sum equals the Batch Amount. Then add the number of transactions for each card type and ensure that the sum equals the Total Number of Transactions in the batch. If it does, click **Settle** to settle the transactions. If there is a discrepancy, you will use the data in the lower window to identify the missing or duplicate transactions.

**FULFILL SETTLED BATCHES**

Click **Fulfill Settled Batches** to complete the Credit Card process. The Credit Card Mark Fulfilled form shown in Figure 6-13 displays. Select the Merchant ID (PPMID) from the drop down list. Select the Authorize.Net™ Batch ID from the drop down list, and the Settlement Date, the Batch Amount, and the Number of Transactions will display. Click **Fulfill** to mark these transactions Approved in the Credit Card Browse.

![Credit Card Fulfillment](image)

**Figure 6-13 Fulfill Settled Batches Form**
EDIT
Credit card transactions may need edits to reconcile problems or entry errors. Selecting **Processes>Edit** displays the Credit Card Edit Form shown in Figure 6-14.

![Credit Card Edit Form](image)

**Figure 6-14 Credit Card Edit Form**

Changes may be made to any blue-coded field, such as Card Number. Select **Exit** to save your changes and return to the Credit Card Browse.

**CHANGE STATUSES**

**Change Statuses** is used to update the status of a batch of credit card payments. The status codes are **Referred**, **Declined**, and **Other**, which are selected by clicking the radio button. When the **Declined** status button is selected, for example, all declined transactions in the selected batch, except those in Hold, are removed from declined status and placed in pending status. This is done to resubmit declined transactions to Authorize.Net™, since many of the declined transactions are declined due to the gateway or the bank...
being offline, etc and not through any faults of the client. The Credit Card Status Change Form is shown in Figure 6-15.

Credit Card Reports
The Credit Card function produces 6 reports.

SETTLED BATCHES/INTERNET BATCHES
These reports list all batches by Authorize.Net™ Batch Number with the PPMID, the Order Number, and the Amounts/Number of Transactions per Credit Card Type. They are used to reconcile system data with the bank deposits from the card providers. When selected, the Credit Card Report Selection form displays.
Enter the range of batches to be included and select Web (Applications) and/or Tags as desired. (Mail-in applications with credit card payment are not accepted in Nevada.)

**INTERNET REVENUE**
This report summarizes the credit card transaction data from the web applications for hunters who applied on the web.

**DECLINE REPORT**
The Decline Report lists all cards that were declined for payment of the permit/tag fees and license fees by Batch Number with the Application Number, the Client Number, the Client Name, the number of Attempts/Status, the Amount, and the Letter Number and Date. In Nevada, the Wildlife Administrative Services Office submits each transaction three times, after which the system marks the record as Hold status. The staff then attempts to contact the cardholder by telephone to resolve the difficulty.

**DOCUMENTS TO PULL REPORT**
This report lists tags and licenses for which credit card approval was not obtained. After the tags are printed, this report is used to pull the unpaid tags and licenses before mailing.

**GRAND TOTAL BY MERCHANT REPORT**
This report summarizes credit card transactions by PPMID, typically two per draw, one for applications and one for tags and licenses.

**Credit Card Views**
There are three views available from the Credit Card Browse – Card Validation, Detail, and Current Year Draw Sort.

**CARD VALIDATION**
Select View>Card Validation in Credit Card Browse to validate a credit card. The screen in Figure 6-17 appears. Enter the card number and click Validate. The system will ascertain whether it is a valid card number and display the reason if it is not.
DETAIL
Selecting **View>Detail** displays the Credit Card Detail Form described previously.

CURRENT YEAR DRAW SORT
Selecting **View>Current Year Draw Sort** displays the current year credit card data in Draw order.

Credit Card Utility
Clicking **Utility** on the Credit Card Browse allows the operator to **Change Draw**, **Convert to Post-Draw**, or **Change (user’s) Password**. These functions are explained elsewhere in the manual.

Credit Card Security
Selecting **Security** in the Credit Card Browse allows the operator to change the Credit Card Password. Click **Change Credit Card Password** to display the Change Password dialog box shown in Figure 6-18.
Type in the old password, enter the new password, re-enter the new password for verification, and click OK to save the change. Only a manager may perform this action.

**Funds Transfer to NDOW**

Once the funds are received by SCI from the card-issuing bank, typically several business days, an ACH transfer is made by the SCI Business Manager, and the ACH Transfer Report is provided to NDOW.

**Summary**